Secunia PSI 2.0.0.3001

なんだかなぁ。
http://d.hatena.ne.jp/noushibou/20110106/1294302523
こっちでPSI起動すればうpだてできると喜んでいたんですが、2.0.0.1001のままだったPSIは

うpだて汁!とは表示されるけど

"Downloaded file has incorrect SHA1Sum"の表示でうpだて失敗。
2.0.0.2001は"A newer version …"すら表示されず。
仕方なく前バージョンアンインストールして2.0.0.3001を手動インストールしますた。